BartPE or Other Bootable Distro Gives Blue Screen 0x0000007B

When using a BartPE, or other bootable distro, your system blue screens with ‘Stop 0x0000007B’.

The most likely cause for this BSOD is due to missing SATA drivers. To solve this problem you can add the correct drivers to your boot disk.  However, this involves you finding the correct drivers and then applying them to your particular boot disk. The easier solution is to change the mode of your disk controller within the BIOS of your system. Depending on your system setup you will have various settings for this device. Likely you will see: RAID, AHCPI, IDE, or Compatible inplace of IDE. You will want to choose Compatible or IDE depending on what you system presents. Reboot after making the change and you should be good to go.

18 Responses to BartPE or Other Bootable Distro Gives Blue Screen 0x0000007B

  1. Antonio S. says:

    Thank you so much for this tip! It worked great!!!

  2. Richard Zink says:

    This advice was on target. I had a an option to Enable or Disable AHCI – Disabling AHCI allowed BartPE (UBCD4Win) to load.

    The only thing I don’t know is if I need to Enable AHCI when booting normally?

    Thanks!

  3. MAiN_PRoToCoL says:

    ya turn it back on after. it should always be on as AHCI is way better than any other option. except RAID of course

  4. home_user says:

    Good Point. I have to turn off AHCI to boot Bart PE, and then turn it back on to boot C:. Otherwise WIn 7 installed on C: drive will not boot smoothly at the first time.

  5. In our case, we set Dell hardware from IRRT to ATA mode instead and it works nicely. Thanks a lot for this.

  6. Shantanu Gadgil says:

    +1
    Disable AHCI and put SATA drives to LEGACY/IDE mode to make BartePE boot. Nice tip!!!

  7. Wayne says:

    Outstanding tip… My problem Dell will now boot Barts PE!!

    Thanks again!

  8. Matt J. says:

    Yep, this is the solution I needed! Thanks!

  9. Lance says:

    With Dell Latitude E6410: Immediately on boot, at Dell logo, hit F12, then go to BIOS menu. Go to System Configuration / SATA Operation, and change ACHI to ATA mode, then change it back after using the BartPE Disk.

    Works!

  10. Lance says:

    Also on the Dell Latitude E6410, you can ignore the warning messages when you change things in the BIOS menu.

  11. Craig says:

    What about systems that don’t provide a bios option to change from AHCI, no options at all? I use UBCD4Win on client’s computers, can’t just load the drivers for one particular system.

  12. Ozzy says:

    Nice, worked right away. Learned something new. Great stuff!

  13. justanonymous says:

    great info on the error. I was getting this for win7 loading winPE found that loading from Sata drive and it being reset (re-enumerated) at startup causing the error. Moved disk to an IDE drive to start and had no issue.

  14. Johnny says:

    Anyone have any ideas what to do when turning SATA compatibility on doesn’t fix the BSOD? Lenovo W510

    • Pantelis says:

      Hey Johnny… I have the same issue! I have a Dell E6410… Turned on ATA compat and BartPE spits out the 0x0000007b BSOD error. I even tried loading the driver (from Dell for the e6410, XP 32 bit storage driver) and nothing… I’ve been trying to get BartPE to boot on this laptop for 3 days now… I’m getting frustrated!!!!!! ;(

      • MAiN_PRoToCOL says:

        Who uses that old junk anymore? Remember that stuff is based on windows XP! A 12 year old OS! Use the real windows PE. They are based from windows 8 and windows 7 sp1

  15. Sumit says:

    Thanks a ton. Worked like a charm…

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

%d bloggers like this: